npm Node Sass version 7.0.1 is incompatible with ^4.0.0.

奥特曼 2022-09-23 08:04:20 阅读数:496

npmnodeSASSversion7.0.1

npm Node Sass version 7.0.1 is incompatible with ^4.0.0.

或者
throw new Error("Module build failed (from ./node_modules/sass-loader/dist/cjs.js):\nError: Cannot find module 'node-sass' 
都是由于升级node后导致sass不兼容

解决方案

1、npm uninstall node-sass;
2、npm i -D sass;
3、运行项目

重启后 如果之前用到了 /deep/ 可能还会遇见

 全局把/deep/改成 ::v-deep  效果也是一样的哈

版权声明:本文为[奥特曼 ]所创,转载请带上原文链接,感谢。 https://blog.csdn.net/m0_46846526/article/details/126985013